WackoWiki: WackoDocDeutsch/Installation/Probleme ...

Home Page | Изменения | Новые Комменты | Пользователи | Каталог | Регистрация | Вход:  Пароль:  

Probleme bei der Installation


Hier k�nnen Sie Fragen zu Problemen w�hrend der Installation stellen.
Оглавление документа

Der webbasierte Installer kann nicht gefunden werden (secure but not web-readable)
Das entpackte Verzeichnis und alle darin enthaltenen Dateien und Unterverzeichnisse sind die (secure but not web-readable) Zugriffsrechte so gesetzt, dass der web-basierte Installer nicht gefunden wird. Der schnellste Weg das Ganze zum laufen zu bringen, jedoch die Installation auch weniger sicher macht, ist in den Ordner zu gehen der das 'wacko' Verzeichnis enth�lt und 'chmod -R 755 wacko' auszuf�hren. Alternativ, alle Verzeichnisse durchgehen und die Zugriffsrechte per chmod den Erfordernissen anpassen.


500 error
Eine m�gliches Fehlerursache auf einigen Webhosts: Die .htaccess Dateien bereiten bei einigen Webhost-Konfigurationen Schwierigkeiten, z.B. erscheint ein '500 error' – und es kann innerhalb des 'wacko' Verzeichnis nichts finden/anzeigen. Das L�schen der .htaccess Dateien sollte das Problem l�sen.


URL-Rewriting funktioniert nicht
Das URL-Rewriting funktioniert bei einigen Webhost-Konfigurationen ebenfalls nicht, und f�hrt zu Funktionsst�rungen bei... In diesen Fall muss bei der Installation das Umschreiben (URL-Rewriting) deaktiviert bleiben. Technische Erkl�rung ...? -> kein apache+mod_rewrite verf�gbar



Fehlermeldung bei der Installation


Warning: array_merge() [function.array-merge]: Argument #2 is not an array in ...\htdocs\wacko\wakka.php on line 132

Warning: array_merge() [function.array-merge]: Argument #1 is not an array in ...\htdocs\wacko\setup\header.php on line 29


�berpr�fe Konfiguration
�berpr�fe MySQL? Verbindung... FEHLGESCHLAGEN

Ursache: Falsche PHP-Version! WackoWiki l�uft derzeit noch nicht mit PHP 5
L�sungsm�glichkeit: andere PHP-Version installieren, bei XAMPP bitte einfach auf PHP 4.3.9 umschalten
Die n�chste Wackoversion ist voll PHP 5 -kompatibel.




Fehlermeldung nach der Installation
Nach der erfolgreichen Installation erscheint am unteren Rand folgende Warnung:

Warning: (null)() [ref.outcontrol]: output handler 'ob_gzhandler' cannot be used twice in Unknown on line 0

Was verbirgt sich dahinter und was muss ich tun, damit die Warnung verschwindet?


L�sung (Quelle: http://wackowiki.com/Comment613)


1. UTF8


SQL-Befehl:

CREATE TABLE `wackowiki_links` (
`from_tag` varchar250 ) binary NOT NULL default '',
`to_tag` varchar250 ) binary NOT NULL default '',
`to_supertag` varchar250 ) NOT NULL default '',
KEY `from_tag` ( `from_tag` , `to_tag` ) ,
KEY `idx_from` ( `from_tag` ) ,
KEY `idx_to` ( `to_tag` )
) TYPE = MYISAM

MySQL meldet: Dokumentation
#1071 - Specified key was too long; max key length is 1000 bytes

http://bugs.mysql.com/bug.php?id=4541

Das Problem liegt an dem Umgang mit Zeichens�tzen. Es kann sein, da� die neueren My SQL- Versionen? so konfiguriert sind, da� der “default-character-set” jetzt “utf8” ist. Damit funktionieren keinerlei Umlaut-Geschichten mehr.


Abhilfe:
In der \mysql\bin\my.cnf von My SQL? den Eintrag «set-variable = default-character-set=utf8» auskommentieren, My SQL? neu starten – und schon funktioniert wieder alles wie gewohnt.

Страницы, ссылающиеся на данную: WackoDocDeutsch/HaeufigeFragen
WackoDocDeutsch/Installation

zur�ck zur �bersicht
 
Файлов нет. [Показать файлы/форму]
Комментарии [Скрыть комментарии/форму]
Добавить комментарий:

Donate
Время работы: 0.223 s
Использовано памяти: 1.529 Mb